Back to overview
Resolved

Down for maintenance!

Jun 23, 2026 at 3:00am UTC  –  Jun 23, 2026 at 7:00am UTC
Affected services
Server Panel
NA-West #1

Resolved
Jun 23, 2026 at 7:00am UTC

Maintenance ended

Created
Jun 23, 2026 at 3:00am UTC

We will be down for 2-4 hours to migrate our infrastructure. More information can be found on our Discord!
https://discord.com/invite/7FG89bNtqV